Postscript call produces graph frame and titles, but no data displayed on the canvas

I have a small program that generates a histogram, and the postscript call

CALL Begin_PostScript( psfile$, 72, 540, 72, 720)
CALL PlotHistFromFreq(Relfreq,"8")
CALL End_PostScript(n)

produces a good quality, complete postscript file.

I have a second small program in which the postscript call

CALL Begin_PostScript("E:\denise4.eps", 40, 1040, 40, 760)
CALL datagraph (times, lane, 1, 0, "black black red")
CALL adddatagraph (times2, lane2, 1, 0, "green")
CALL End_PostScript(n)

produces a file with frame and titles, but not the line graphs. The graph is displaying on the screen just fine, but the canvas isn't getting into the postscript file.

CALL Begin_PostScript("E:\denise4.eps", 40, 1040, 40, 760)
CALL datagraph (times, lane, 1, 0, "black black red")
CALL End_PostScript(n)

also produces an empty canvas in the postscript file.

Any suggestions?

Thanks,

Bill Roberts

Comments

re: postscipt output

I'll only reply here because no one else has and the fact that I know nothing about postscript doesn't deter me. :-)

I'd try changing things in your failed program--things like the frame boundaries (is 1040 OK?) or even try a different data file. But I suspect you have. The TB download document about postscript is now 15 years old so basically worthless other than I think it suggests getting a 'free' postscript utility and perhaps chaining out to that to do the printing. There are warnings about the fact that network printers may not work correctly too.

Anyway, not much help but I'd experiment with simple files with different parameters to see if you can get it to work at all.

rwt